Download Interconexão de redes de computadores PDF

TitleInterconexão de redes de computadores
File Size7.3 MB
Total Pages342
Table of Contents
                            Sessão de aprendizagem 1
	Arquiteturas de protocolos
		Interconexão de redes – Motivação
		Redes – Bastidores
		Redes – Convergência
		“TI não é a rede, mas os seus usuários!”
		Exemplo: Permitindo suporte a acesso remoto
		Conceito de rede
		Protocolos de rede
		ISO e o modelo OSI
		Modelo em camadas – Objetivos
		Modelo em camadas – Visão geral
		Camada física – Funções
		Camada física – Exemplos de mídia
		Camada física – Interfaces
		Camada física – Implementação LAN
		Camada física – Dispositivos
		Camada de enlace – Funções
		Camada de enlace – Dispositivos
		Camada de rede
		Camada de rede – Funções e dispositivos
		Camada de rede – Funções
		Camada de transporte
		Camada de transporte – Funções
		Camada de transporte – Estabelecimento de conexão
		Camada de sessão
		Camada de sessão – Funções e exemplos
		Camada de apresentação
		Camada de aplicação
		Encapsulamento de dados
		Comunicação Peer-to-Peer
		Visão geral – Ethernet
		IEEE 802.3 / Ethernet
		Endereço MAC
		IEEE 802.3 / Ethernet
		Tipos de quadros Ethernet
		IEEE 802.3 / Ethernet
		IEEE802.3u / Fast Ethernet
		IEEE802.3ab / Gigabit Ethernet
		IEEE802.3ae / 10 Gigabit Ethernet
		Cabeamento Ethernet
		Wireless Ethernet (IEEE 802.11)
		Roteiro de atividades
		Atividade 1 – Uso do simulador Netsimk
Sessão de aprendizagem 2
	Arquitetura TCP/IP
		Modelo DoD
		Concepção da arquitetura TCP/IP
		Pilha de protocolos TCP/IP
		Camada de transporte – TCP/UDP
		Protocolo TCP – Funções
		Número de portas
		Abertura de conexão TCP
		Reconhecimento simples TCP
		Janela deslizante TCP
		Camada internet da arquitetura TCP/IP
		Cabeçalho do datagrama IP
		Campo “Protocolo do datagrama IP”
		Internet Control Message Protocol (ICMP)
		Classes de endereçamento IP
		Endereçamento IP
		Endereçamento de host
		Exemplos de classes de endereços IP
		Tabela de subredes
		Máscara de subrede sem subredes
		Máscara de subrede com subredes
		Endereço de broadcast
		Network Address Translation – Motivação
		Funcionamento de NAT
		Vantagens e desvantagens de NAT
		Endereços privados
		Exemplos NAT
		Terminologia NAT
		Exemplo NAT
		Tipos de NAT
		NAT Estático
		Comandos de configuração de NAT Estático
		Exemplo de configuração de NAT Estático
		NAT dinâmico
		Configurando NAT Dinâmico
		Port Address Translation (PAT)
		Exemplo de PAT
		Configurando PAT
		Distribuição de carga TCP
		Configurando distribuição de carga TCP
		Redes sobrepostas (Overlapping Networks)
		Configurando redes sobrepostas
		Verificando redes sobrepostas
		Verificando traduções NAT
		Resolução de problemas em traduções NAT
		Limpando traduções NAT
		Network Address Translation – Resumo
		Tradução de endereços
		Tradução dinâmica com overload (PAT)
		Distribuição de carga TCP
		Roteiro de atividades
		Atividade 1 – Análise do protocolo TCP
		Atividade 2 – Laboratório de NAT/PAT: NAT Estático e Dinâmico
		Atividade 3 – Laboratório de PAT
Sessão de aprendizagem 3
	Roteamento
		Conceito de roteamento
		Transporte dos pacotes
		Exemplo de roteamento IP
		Arquitetura de 3 camadas
		Cálculo de subrede
		IP Subnet Calculator
		VLSM – Máscara de subrede de tamanho variável
		Exemplo de VLSM
		Roteiro de atividades
		Atividade 1 – Configuração básica de roteador e VLSM
Sessão de aprendizagem 4
	Switches Ethernet
		Comutação na camada 2
		Modo de operação Half-duplex
		Modo de operação Full-duplex
		Configurando Velocidade e Modo de Operação
		Enviando/Recebendo quadros Ethernet numa topologia barramento
		Repetidores (Hubs)
		Repetidores
		Hubs
		Enviando/Recebendo frames Ethernet via hub
		Métodos de acesso
		CSMA/CD (Carrier Sense Multiple Access com Collision Detection)
		Domínio de colisão: Ambiente de acesso compartilhado
		Onde seriam os domínios de colisão?
		Quais seriam as configurações de half/full duplex?
		Enviando/Recebendo frames Ethernet via switch
		Troubleshooting Ethernet
		Address Resolution Protocol
		Reverse ARP
		Spanning Tree Protocol (STP)
		Spanning Tree – Somente para loops
		L2 loops – Flooded unicast frames
		Broadcast de camada 2
		STP evita loops
		Dois conceitos chave em STP
		Bridge ID (BID)
		Path Cost – Revised Spec (Non-Linear)
		Seqüência de decisão de 5 passos
		Eleição da root bridge
		Eleição da root bridge: menor BID vence
		Eleição da root bridge
		Convergência STP
		Eleição de root ports
		Decisão do switch “Distribution 1”
		Decisão dos outros switches
		Eleição de designated ports
		Estados de porta – Spanning Tree
		Temporizadores STP
		Rapid Spanning Tree Protocol (RSTP)
		RSTP versus STP
		RSTP – Funções das portas
		Roteiro de atividades
		Atividade 1 – Funcionamento do broadcast ARP
		Atividade 2 – Funcionamento do algoritmo Spanning Tree
Sessão de aprendizagem 5
	VLANs – Redes locais virtuais
		VLAN – Introdução
		Duas subredes e um switch, sem VLANs
		Solução tradicional: Múltiplos switches
		Domínios de broadcast com VLANs e roteador
		VLAN estática
		VLAN dinâmica – Operação
		VLAN Trunking / Tagging
		IEEE 802.1Q
		IEEE 802.1Q – Detalhamento
		IEEE 802.1ad (QinQ)
		Criando VLANs
		Configuração de VLANs estáticas
		Configurando faixas de VLANs
		Verificando VLANs – show vlan
		Acessando e gerenciando o switch
		Configurando Trunking
		VLAN Trunking Protocol (VTP)
		Modos de operação VTP
		Roteamento Inter-VLAN
		Interfaces lógicas
		Roteamento Inter-VLAN – Trunk links
		Roteiro de atividades
		Atividade 1 – Projeto de rede com VLANs em switches
Sessão de aprendizagem 6
	Protocolos WAN – Parte 1
		WAN – Conceitos
		Nomenclatura
		Dispositivos CSU / DSU WAN
		A camada física WAN
		Dispositivos WAN
		Padrões WAN
		Visão geral WAN – Camada de enlace
		Tipos de conexão e velocidades
		Visão geral WAN – Tipos
		Rede de circuitos (Circuit switching)
		Rede de pacotes (Packet switching)
		Tecnologias WAN
		Serviço de linha digital dedicada
		Linha digital de assinante – Banda larga
		Redes ópticas síncronas
		Tecnologias WAN
		Serviços analógicos – Modems discados
		Serviços analógicos – Cable modem
		Serviços analógicos – Wireless
		Projetos WAN
		Projetos WAN – Requisitos das aplicações
		Projetos WAN – Fases
		Projetos WAN – Topologias
		Projetos WAN – Abordagem hierárquica
		Vantagens da abordagem hierárquica
		Projetos WAN – Abordagem não hierárquica
		Projetos WAN – Internet como WAN
		Service Provider
		Novas tecnologias WAN – MPLS
		Novas tecnologias WAN – WiMAX
		WiMAX – Modulação Adaptativa
		Novas tecnologias WAN – DWDM
		Novas tecnologias WAN – Metro Ethernet
		Comparação HDLC e PPP
		Point-to-Point Protocol (PPP) – Visão geral
		Mapeamento PPP com modelo OSI
		Configuração PPP – Opções LCP
		Fases PPP – Visão geral
		Fase de autenticação (opcional)
		Opções de autenticação PPP
		Autenticação PAP
		Autenticação CHAP
		Operação CHAP
		Compressão PPP
		Configurando compressão
		Configurando PPP Multilink (MLP)
		Roteiro de atividades
		Atividade 1 – Configurar o enlace WAN
		Atividade 2 – Alterar o encapsulamento para PPP
		Atividade 3 – Configurar a autenticação PPP
Sessão de aprendizagem 7
	Protocolos WAN – Parte 2
		Tecnologias WAN
		Tecnologias WAN Comutadas
		Protocolo X.25
		Protocolo Frame Relay
		Visão geral – Conceitos
		Dispositivos Frame Relay – DCE / DTE
		Dispositivos Frame Relay – UNI / NNI
		Frame Relay – Operação
		Frame Relay – Operação (VC)
		Data Link Connection Identifier (DLCI)
		Controle de tráfego e congestionamento
		Local Management Interface (LMI)
		Mapeamento DLCI para endereço IP
		Mapeamento DLCI para endereço IP: IARP
		Configuração mínima de Frame Relay
		Configurando Inverse ARP
		Endereço IP Remoto
		Verificando PVC Frame Relay
		Topologias Frame Relay
		Configuração Topologia Estrela (hub and spoke)
		Configuração usando Inverse ARP
		Problemas de conectividade: Routing Updates
		Configurando subinterfaces Frame Relay
		Configurando subinterfaces Frame Relay ponto a ponto
		Configurando subinterfaces Frame Relay multiponto
		Tecnologias WAN
		Visão geral
		Arquitetura ATM
		Categorias de serviço ATM
		Roteiro de atividades
		Atividade 1 – Laboratório de Frame Relay: ponto a ponto e Inverse ARP
		Atividade 2 – Laboratório de Frame Relay: ponto a ponto sem Inverse ARP
		Atividade 3 – Laboratório de Frame Relay: Hub and Spoke
Sessão de aprendizagem 8
	Protocolos WAN – Parte 3
		Conceito de broadband
		Broadband
		Satélite
		Satélites geoestacionários (GEOSs)
		Satélites não-estacionários
		TV a cabo (cable TV)
		TV a cabo – DOCSIS
		Cable modem
		Dados sobre cabos
		Arquitetura Híbrida Fibra-Coaxial (HFC)
		Digital Subscriber Line (DSL)
		Intervalo de freqüência de DSL
		Implementações de DSL
		Limitações da tecnologia DSL
		ADSL
		Dados sobre ADSL com bridging
		Dados sobre ADSL: PPPoE
		Configurando PPPoE num grupo VPDN
		Configurando PAT
		PAT com exemplo DSL
		Configurando uma rota estática default
		Configuração final PPPoE / DSL
		Dados sobre ADSL com PPPoA
		Configuração da interface DSL ATM
		Checando a interface ATM
		Roteiro de atividades
		Atividade 1 – Configuração de roteador ADSL
Sessão de aprendizagem 9
	Gerência de redes
		Importância do gerenciamento
		Atuação do Gerente de Redes
		Arquiteturas num modelo organizacional
		Componentes do modelo organizacional
		Introdução à estrutura de MIB
		Modelo de comunicação
		Modelo funcional
		Gerência de falhas
		Ferramentas para gerência de falhas
		Ferramentas para gerência de falhas: Traceroute
		Gerência de configuração
		Gerência de contabilização
		Gerência de contabilização (ferramentas)
		Gerência de desempenho
		Gerência de segurança
		Como abordar os 5 itens da gerência funcional?
		Ferramenta para gerenciamento dos 5 elementos da gerência funcional (sniffer)
		Fluxo de mensagens em SNMP
		MIB OID
		MIB-II
		Definição de objetos no SNMP
		Modelo operacional SNMP
		Protocolo SNMP: versões
		Configuração SNMP
		RMON
		Monitor Remoto (RMON)
		Syslog – log de eventos
		Tendências futuras – protocolo de gerenciamento
		Roteiro de atividades
		Atividade 1 – Ativando SNMP no Windows XP
		Atividade 2 – Instalando MIB Browser
Sessão de aprendizagem 10
	Resolução de problemas
		Orientações gerais
		Metodologia geral de Troubleshoot
		Formação de grupos de trabalho
		Problemas propostos
		Apresentação das soluções
		Roteiro de atividades
		Atividade 1 – RedeTeste1
		Atividade 2 – RedeTeste2
		Atividade 3 – RedeTeste3
		Atividade 4 – RedeTeste4
Bibliografia
                        
Document Text Contents
Page 2

Escola Superior de Redes RNP

Copyright © 2007, Escola Superior de Redes RNP

Autores

Luiz Carlos Lobato Lobo de Medeiros

Igor Briglia Habib

Revisão final

Pedro Sangirardi

Editoração eletrônica

Tecnodesign

Coordenação acadêmica

Luiz Coelho

Versão

1.1.0

Todos os direitos reservados, no Brasil, por

Escola Superior de Redes RNP

http://www.esr.rnp.br

Page 171

171

VLANs – Redes locais virtuais

Enter configuration commands, one per line. End with
CNTL/Z.

Sw3(config)#interface vlan 1

Sw3(config-if)#ip address 10.0.10.3 255.255.255.0

Sw3(config-if)#no shutdown

Sw3(config-if)#

%LDXX - Interface vlan 1, changed state to up

Sw3(config-if)#ex

Sw3(config)#ip default-gateway 10.0.10.254

10. Caso você executasse um comando ping de qualquer PC para outro em
mesma VLAN, você obteria sucesso?

Para responder a esta pergunta, vamos fazer o seguinte teste:

ping Adm3 (IP: 10.0.20.9) para Adm2 (IP: 10.0.20.5), ambos da VLAN2.

O resultado deve ser parecido com o mostrado a seguir.

O ping funcionou porque, por default, todas as portas são configuradas como
“switchport mode dynamic desirable”. Logo, se uma porta for conectada a outro
switch com porta configurada no mesmo modo default (desirable ou auto), o
enlace se tornará um “trunking link”. Portanto, os entroncamentos de VLAN foram
montados automaticamente.

Page 172

172

Interconexão de Redes de Computadores – Sessão de aprendizagem 5

Escola Superior de Redes RNP

Atividade 1.3 – Configuração de entroncamento de switches usando 802.1q

1. Configuração dos enlaces de entroncamento de VLANs em todos os
switches.

Configuração de VLANs no Sw1:

Sw1#conf t

Enter configuration commands, one per line. End with
CNTL/Z.

Sw1(config)#interface GigabitEthernet0/1

Sw1(config-if)#switchport mode trunk

Sw1(config-if)#interface GigabitEthernet0/2

Sw1(config-if)#switchport mode trunk

Configuração de VLANs no Sw2:

Sw2#conf t

Enter configuration commands, one per line. End with
CNTL/Z.

Sw2(config)#interface GigabitEthernet0/1

Sw2(config-if)#switchport mode trunk

Sw2(config-if)#interface GigabitEthernet0/2

Sw2(config-if)#switchport mode trunk

Page 341

Bibliografia

BRISA (Sociedade Brasileira para Interconexão de Sistemas Abertos). \\ Gerenciamento
de redes: uma abordagem de sistemas abertos. Makron Book, 1 ed., 1993.

FEIT, Sidnie. \\ SNMP: A guide to Network Management. McGraw-Hill, 1 ed., 1995.

HARNEDY, Sean. \\ Total SNMP: Exploring the Simple Network Management Protocol.
Prentice-Hall, 2 ed., 1997.

LOPES, Raquel V.; SAUVÉ, Jacques P.; NICOLLETTI, Pedro S. \\ Melhores práticas
para gerência de redes de computadores. Campus, 1 ed., 2003.

PERKINS, Avid. \\ Understanding SNMP MIBs. Prentice-Hall, 2 ed., 1993.

ROSE, Marshall. \\ The Simple Book. Prentice-Hall, 2 ed. revisada, 1996.

ROSE, M.; McCLOGHRIE, K. \\ How to Manage your Network Using SNMP – The
Network Management Practicum. Prentice Hall, 1995.

SCHMIDT, Mauro. \\ Essential SNMP. O’ Reilly, 2 ed., 2005.

STALLINGS, William. \\ SNMP, SNMPv2, SNMPv3 e RMON 1 e 2. Addison-Wesley, 3
ed., 1999.

STALLINGS, William. \\ Data and Computer Networks. Prentice-Hall, 2004.

STEVENS, W. Richard; WRIGTH, Gary R. \\ TCP/IP Illustrated. Vols. 1 e 2. Prentice
Hall, 1998.

TANENBAUM, Andrew S. \\ Rede de Computadores. Editora Campus, 2003.

CCNA ICND Exam Certification Guide (CCNA Self-Study, 640-811, 640-801).\\

CCNP BCRAN Exam Certification Guide (CCNP Self-Study, 642-821) 2 ed.\\

Inc. Cisco Systems. \\ Internetworking Technologies Handbook. 2 ed., Cisco Press,
2000.

Networkers 2006/7 presentations (Cisco Conference).\\

Similer Documents